iOS SDK not working with Xcode 10

Solved!
Posted in General by Anand T Fri Oct 12 2018 04:34:50 GMT+0000 (Coordinated Universal Time)·6·Viewed 975 times

We are using InstaMojo on one of our Mobile app that works in Android. Now we are creating it’s iOS version. So we have integrated the instamojo into our project using cocoapod as stated below but it returns error. Could you please rebuild the sdk with Xcode 10 and iOS 12 at the earlier. ***POD FILE*** pod 'Instamojo', :git => 'https://github.com/Instamojo/ios-sdk.git', :tag => '1.0.15' pod 'InstaMojoiOS', '0.0.3' ***BUILD ERROR*** ld: /Users/anand/Documents/MyProject/Pods/InstaMojoiOS/InstaMojoiOS-Release-iphoneuniversal/InstaMojoiOS.framework/InstaMojoiOS compiled with older version of Swift language (4.0) than previous files (unknown ABI version 0x06) file '/Users/anand/Documents/MyProject/Pods/InstaMojoiOS/InstaMojoiOS-Release-iphoneuniversal/InstaMojoiOS.framework/InstaMojoiOS' for architecture x86_64 clang: error: linker command failed with exit code 1 (use -v to see invocation)
Instamojo
Oct 15, 2018

Hi Anand,

We are under the process of upgrading our SDK to the latest Swift and Xcode version.
We currently do not have an ETA on the same.

We request your kind understanding and co-operation on this.

I will be getting back to you at the earliest with the update once it is released.


Instamojo marked this as solved
NATARAJAN
Nov 23, 2018

Hi InstaMojo team,

I am working with Objective c . I am using ios 10.12.6. When install pod using

pod 'Instamojo', :git => 'https://github.com/Instamojo/ios-sdk.git', :tag => '1.0.15'
pod 'InstaMojoiOS', '0.0.3'

I am getting pod install error.

[!] Unable to find a specification for InstaMojoiOS (= 0.0.3)

Anand T
Nov 23, 2018

For those who are looking for the solved answer, I used following in the pod file for Xcode 10.1.

pod 'Instamojo', :git => 'https://github.com/Instamojo/ios-sdk.git', :tag => '1.0.16'

(No need to use 'InstaMojoiOS')

Read more: https://docs.instamojo.com/v1.1/page/ios-sdk

NATARAJAN
Nov 23, 2018

Hi, when i use

Request *request = [[Request alloc] initWithOrderID:orderID accessToken:accessToken orderRequestCallBack:self];
[request execute];

I am getting

No visible @interface for 'Request' declares the selector 'initWithOrderID:accesstoken:orderRequestCallBack:'

Gaurav
Jan 1, 2019

Issue is marked resolved. But I'm still facing the same error message.

Susheel Kumar Yadav
Jan 17, 2019

@Anand T, I have used above mentioned pod file ( pod 'Instamojo', :git => 'https://github.com/Instamojo/ios-sdk.git', :tag => '1.0.16' ) in my Objective-C project, Still facing with same error

Error :
dyld: Library not loaded: @rpath/libswiftCore.dylib
Referenced from: /Users/admin/Library/Developer/CoreSimulator/Devices/F03965FF-EEC8-4FB1-BFF5-71F2C3DE3E11/data/Containers/Bundle/Application/BDAE01BE-0CB5-40F5-8A66-B20763A99BDB/ddd.app/Frameworks/Instamojo.framework/Instamojo
Reason: image not found

Can you please help me out.

Markdown is allowed